Customer Service

If you’re already a Neuwave Systems customer and you have a question or need technical support, please fill out the form below or give us a call at (919) 878 8747.

If you need immediate assistance and it is after business hours, call our 24/7 service line at (919) 398-3594 or read our Frequently Asked Questions below to find fixes for common technical issues.

FAQs

My wireless internet is slow or has no connection at all

Reboot your modem and router by unplugging the power cord from each for about 1 minute. Plug the power cords back into the modem and the router but don’t switch them on yet. First turn on your modem and wait for it to initialize, which will take around 5 minutes. Then switch on the router and give it about 5 minutes to reboot. Unplug both then reconnect the modem first, wait 5 minutes and reconnect the router and give it 5 minutes to reboot.  If you have an Apple router, confirm the light on the front is green. If you still do not have internet, contact us for service.

My Control4 system isn’t working or the remote says it’s waiting for network

Reboot the Control4 controller by unplugging the power cord for 1 minute and plugging it back in.  Wait 5 minutes, then remove the batteries from the remote and put them back in. Confirm that there are two solid blue lights on the front of the controller, one for power and one for link.  If the wifi or data lights are lit up or flashing any color, contact us for service.

I’m getting video but no audio from my cable/satellite box.

Reboot your cable/satellite box by unplugging the power cord for 1 minute and plugging it back in. Make sure the box is powered on after the reboot is complete. You may need to manually power it on from the power button on the front. If you still do not have audio, contact us for service.

I’m getting audio but no video from my cable/satellite box

First check other video sources (Bluray, AppleTV, etc) and see if they have video or not. If the other video sources have video and audio, reboot the cable/satellite box by unplugging the power cord for 1 minute and plugging it back in.  If the other sources do not have video, try rebooting your AV receiver by unplugging the power cord for 1 minute and plugging it back in. If you still don’t have video, contact us for service.